I have a ford fiesta fitted with kenwood music system and

Tell us more about yourself

 

Please let us know your details to help us answer your question.

 

 

 
I have a ford fiesta fitted with kenwood music system and the speakers are company fitted, recently i fixed a sub woofer and a 2 channel amp both jbl make, the sub-woofer is kept in the boot as insisted by the dealer, but i am not getting the affect inside the car and also there is lot of vibration, if you have any solutions kindly let me know.
  • 3625 day(s) ago by Vivek
Under: Ford Fiesta #Cars
3
Answer(s)
Post an Answer

Answers submitted by Users


Rijish
Fiat
Palio
Owner
Acoording to u there are two problems that you are facing. ist is lack of punch for the woofer. it depends on how powerful your woofer and amp is. if it is then u will have to fine tune your amp that you ll get a proper balance between the rest of the speakers and the wooofer. regarding the vibration its un avoidable. if you are having rattles then it can be fixed by proper damping. get in touch with a good car audio shop to get it fixed.
 

Posted: 3624 day(s) ago


Jayanth
Hyundai
i10
Owner
if ur fixing in boot... just fix bass tube of jbl brand (1200 watts). i have faced a same problem .. now its solved ..... the bass tube is design for this sake..........
 

Posted: 3624 day(s) ago

Hi,
As mentioned by Jayanth, fixing a base tube should give better effects and lesser vibration.
 

Posted: 3619 day(s) ago


Post Your Answer Here

Type the characters you see in the image below

Recently Asked Questions

Find New Cars

By Brand

Get complete details of new cars

By budget

5 Lakh to 10 Lakh

Ad
Ad